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Preface 
 
 
A generic Decision-Support Method (DSM) for Sustainable Urban Drainage Systems (SUDS) 
selection and where to locate these solutions has been developed. The method will help 
decision makers and city planners to make sound decisions based upon knowledge of where 
the water will accumulate and where to find the most optimal location for installing stormwater 
measures. 
 
Klima 2050 - Risk reduction through climate adaptation of buildings and infrastructure is a 
Centre for Research-based Innovation (SFI) financed by the Research Council of Norway and 
the consortium partners. The SFI status enables long-term research in close collaboration with 
private and public sector, as well as other research partners aiming to strengthen Norway's 
innovation ability and competitiveness within climate adaptation. The composition of the 
consortium is vital in order to being able to reduce the societal risks associated with climate 
change.  
 
The Centre will strengthen companies’ innovation capacity through a focus on long-term 
research. It is also a clear objective to facilitate close cooperation between R&D-performing 
companies and prominent research groups. Emphasis will be placed on development of 
moisture-resilient buildings, storm water management, blue-green solutions, measures for 
prevention of water-triggered landslides, socio-economic incentives and decision-making 
processes. Both extreme weather and gradual changes in the climate will be addressed. 
 
The host institution for SFI Klima 2050 is SINTEF, and the Centre is directed in cooperation 
with NTNU. The other research partners are BI Norwegian Business School, Norwegian 
Geotechnical Institute (NGI), and Norwegian Meteorological Institute (MET Norway).  
 
The business partners represent important parts of Norwegian building industry; consultants, 
entrepreneurs and producers of construction materials: Skanska Norway, Multiconsult AS, 
Mesterhus/Unikus, Norgeshus AS, Leca AS, Isola AS, Skjæveland Gruppen AS and Powel 
AS. The Centre also includes important public builders and property developers: Statsbygg, 
Statens vegvesen, Jernbanedirektoratet and Avinor AS. Key actors are also Trondheim 
kommune, The Norwegian Water Resources and Energy Directorate (NVE) and Finance 
Norway.  
 
 
 
 
 

Trondheim, August 2019 
 
 

Berit Time 
Centre Director 

SINTEF Community 
 

 
 
 

 
 
 



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 5 

Table of Contents  
PREFACE ............................................................................................................................................. 4 
LIST OF ABBREVIATIONS .............................................................................................................. 6 
1 INTRODUCTION ..................................................................................................................... 7 
2 DECISION-SUPPORT METHOD FOR SUDS IMPLEMENTATION ............................... 8 

2.1 6 STAGES IN THE DECISION-SUPPORT METHOD ...................................................................... 8 
2.2 GIS ANALYSIS ........................................................................................................................ 9 

2.2.1 Potential SUDS Area Detection ...................................................................................... 10 
2.2.2 Main Flow Path Determination ...................................................................................... 10 
2.2.3 High Potential SUDS Area Detection ............................................................................. 11 

2.3 SOFTWARE ............................................................................................................................ 11 
3 GENERAL GUIDELINE SETTINGS ................................................................................... 12 
4 DATA ACQUISITION AND PRE-PROCESSING .............................................................. 13 

STEP 1 DEFINE COORDINATION REFERENCE SYSTEM (CRS) ............................................................ 13 
STEP 2 DETERMINE PROJECT EXTENSION AND COORDINATES ........................................................... 15 
STEP 3 GET INPUT ELEVATION DATA ................................................................................................ 17 
STEP 4 GET INPUT BUILDINGS AND INFRASTRUCTURE DATA ............................................................ 20 
STEP 5 GET ORTHOPHOTOS AND BACKGROUND MAPS ...................................................................... 24 
STEP 6 ADD ROUGH OPEN STREET MAP VECTOR DATA .................................................................... 26 
STEP 7 VALIDATE AND CORRECT OPEN STREET MAP VECTOR DATA FOR BUILDINGS ....................... 30 
STEP 8 VALIDATE AND CORRECT OPEN STREET MAP VECTOR DATA FOR LAND USE ........................ 33 
STEP 9 (OPTIONAL) MODIFY OPEN STREET MAP VECTOR DATA FOR STREETS .................................. 41 
STEP 10 (OPTIONAL) VALIDATE AND CORRECT OPEN STREET MAP VECTOR DATA 
FOR STREETS ..................................................................................................................................... 45 
STEP 11 CHECK FEATURES FOR TOPOLOGY ERRORS ...................................................................... 47 
STEP 12 CREATE CATCHMENT AREA VECTOR ................................................................................ 50 

5 SUDS AREA DETECTION ALGORITHM – STEP BY STEP .......................................... 51 
STEP 1 ADJUST RASTER INPUT ......................................................................................................... 51 
STEP 2 DETERMINE LAND USE RASTER ........................................................................................... 52 
STEP 3 CREATE COMBINED ELEVATION MODEL .............................................................................. 56 
STEP 4 CALCULATE SURFACE SLOPE ............................................................................................... 58 
STEP 5 DETERMINE POTENTIAL SUDS AREAS ................................................................................. 60 
STEP 6 CALCULATE FLOW ACCUMULATION..................................................................................... 62 
STEP 7 DETERMINE MAIN FLOW PATHS ........................................................................................... 64 
STEP 8 DETERMINE HIGH POTENTIAL SUDS AREA ......................................................................... 67 
STEP 9 CHECK FEATURES FOR TOPOLOGY ERRORS ........................................................................... 74 

6 SUDS AREA DETECTION ALGORITHM – COMBINED MODELS ............................. 76 
MODEL 1 POTENTIAL SUDS AREA DETECTION .............................................................................. 77 
MODEL 2 MAIN FLOW PATH DETERMINATION ................................................................................ 79 
MODEL 3 HIGH POTENTIAL SUDS AREA DETECTION ..................................................................... 82 

LITERATURE .................................................................................................................................... 84 
 
  



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 6 

 
List of Abbreviations 

 
CRS Coordination Reference System 

DSM Decision Support Method 

dsm Digital Surface Model 

dtm Digital Terrain Model 

ETRS89 European Terrestrial Reference System 1989 

GDAL Geospatial Data Abstraction Library (http://www.gdal.org)  

GIS Geographic Information System 

OSM Open Street Map 

OTF On the fly coordinate transformation 

SUDS Sustainable Urban Drainage Systems 

tmp temporal 

UTM Universal Transverse Mercator 

WGS World Geodetic System 

WMS Web Map Service 
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1 Introduction 
 
A generic Decision-Support Method (DSM) for Sustainable Urban Drainage Systems 
(SUDS) selection and where to locate these solutions has been developed. The 
method will help decision makers and city planners to make sound decisions based 
upon knowledge of where the water will accumulate and where to find the most 
optimal location for installing stormwater measures. Giving reliable decision-support, 
knowledge about topological, geological and technical conditions is required (Woods 
Ballard, Wilson et al. 2015), and the objective of the DSM has been to obtain, organise 
and use this knowledge in a structured way. 
 
This guideline gives in Chapter 2 an introduction to the DSM, with focus on the GIS 
analysis and the detection of potential SUDS areas. The remaining chapters presents 
in more detail the GIS analysis and the different steps needed; that is Chapter 3 
presents the settings and nomenclature used to describe the GIS operations, Chapter 
4 presents the data acquisition and data pre-processing steps, Chapter 5 presents 
the SUDS area detection steps, whereas Chapter 6 presents the pre-defined models 
that has been developed combining different steps from Chapter 5 into complete 
models. 
 
As an example of application of the developed DSM, please refer to Muthanna et al. 
(2018). In this paper the Gløshaugen Campus in Trondheim, Norway, has been used 
as a case. 
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2 Decision-Support Method for SUDS implementation 

2.1 6 stages in the Decision-Support Method 
 
The developed Decision-Support Method (DSM) is structured in six stages as 
illustrated in Figure 1 as well as Table 1. Table 1 also shows the type of action each 
stage represents, i.e. GIS analysis, Field measurements, Design or Expert planning. 
 
 

 
Figure 1:  Stages of the Decision-Support Method (DSM) for a Sustainable Urban 

Drainage Systems (SUDS) planning process. 

 
In stage 1 possible SUDS areas are detected by analysing the topological properties 
using a geographic information system (GIS), followed by a ranking of the areas as 
either potential or high-potential areas for SUDS implementation. After detecting 
potential and high-potential areas for SUDS implementation, the soil properties of 
these areas will be determined in Stage 2. Field measurements to determine the 
infiltration rate, the groundwater level and the soil characteristics may be necessary 
at this stage.  
 
In Stage 3 it is recommended to assess the national and local guidelines to determine 
the technical and dimensioning requirements that apply for the area of interest. In 
addition, the performance for different SUDS measures needs to be assessed, and if 
necessary, modified to local climatic conditions.  
 
Stage 4 combines the information gathered in the three first stages, i.e. i) possible 
SUDS areas from Stage 1, ii) infiltration capacity from Stage 2, and, iii) technical 
requirements and design criteria from Stage 3. This information will enable the expert 
planners to determine where on the site and which SUDS measures that are 
realizable for the area of interest. The information about where to and which SUDS to 
implement, is used in Stage 5 to simulate the impact on the storm water runoff for 
different scenarios. The result from the simulations are then used in Stage 6 to select 
the most efficient combination of SUDS measure for the area of interest. The final 
selection in Stage 6 may also depend on other factors, such as environmental, 
economic and social, but details about these factors are not considered here. 
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Table 1:  Stages in the Decision-Support Method. 

Stage Action Type of action 

1 Detect possible SUDS areas (see Figure 2) GIS analysis 

2 Determine soil properties Field measurements  

3 Apply construction conditions Design/ Dimensioning  

4 Select possible SUDS solutions Expert planning 

5 Determine possible impact reduction Expert planning 

6 Give decision support for SUDS solutions Expert planning 
 
 
2.2 GIS analysis 
 
The GIS analysis in Stage 1 determines the areas within the catchment that are 
available for SUDS implementation and evaluate these areas by their potential for 
SUDS implementation. The overall approach taken is given in Figure 2 and is split 
into three main steps: 1. Potential SUDS Area Detection which focus on surface and 
infrastructure analysis; 2. Main Flow Path Determination to show surface runoff paths 
within the area of interests; 3. High Potential SUDS Area Detection which select 
SUDS areas close to surface runoff. This stepwise approach is selected to provide an 
easy to follow and simple procedure to reproduce catchment analysis. As shown in 
Figure 2, the approach depends only on basic information, which for most regions 
have the advantage to be open source. Inputs are digital elevation model raster and 
vector data for land use and infrastructure. The three main steps of the approach are 
described in more detail in the following subsections.  
 
 

 
Figure 2:  Main steps in the Decision Support Method - Stage 1 Detect Possible SUDS 

Area:1. Potential SUDS Area Detection; 2. Main Flow Path Determination; 3. 
High Potential SUDS Area Detection. 
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2.2.1 Potential SUDS Area Detection 
 
The first factor needed to identify possible locations for SUDS measure is the 
availability of undeveloped area. Undeveloped area in this case could be unused 
green areas, inactive courtyards or storage areas. Also, areas like parking place, 
where a reduction of the pervious area is planned, could be "undeveloped" in the 
broad sense of this method. The area must be available as vector data in a GIS and 
can be extracted from existing available urban vector e.g. from Open Street Map, or 
manually added using orthophotos or similar map services.  
 
Next, based on a digital elevation model (DEM), the slope of the surface is calculated 
using elevation values from the raster data and the 9 parameters 2nd order polynomic 
method (Zevenberg & Thorne, 1987). The slope of the surface comprises the second 
main factor to determine potential SUDS areas and are divided into two categories, 
low surface slope areas and high surface slope areas. The categorisation is based on 
technical recommendations typical for infiltration measures, where a recommend 
maximum surface slope for surface infiltration measure like swales is 10 % (Woods 
Ballard, et al., 2015). The low slope areas will ensure lower investment costs for 
surface modification, higher natural storage capacities and longer infiltration times 
due to low flow velocities compared to the high slope areas. 
 
Areas fulfilling these two factors are defined as Potential SUDS Areas and will have 
the potential for positive impacts on the urban water balance, due to the ability to hold 
and handle storm water.  
 
2.2.2 Main Flow Path Determination 
 
It is possible to create a general view of the surface runoff situation by using spatial 
flow tracing and resulting flow accumulation methods in GIS. The GIS calculation uses 
elevation data from the DEM to determine the flow direction of a flow line. To ensure 
uninterrupted flow lines, local surface depressions in the DEM are filled, using a sink 
filling algorithm (Wang & Liu, 2006). Flow accumulation shows for each cell in a DEM 
raster the number of cells which flow lines pass through that grid cell (López-Vicente, 
Pérez-Bielsa, López-Montero, Lambán, & Navas, 2014). This means that the number 
of flowlines from the entire map which have segment endpoints within that cell will be 
shown for each DEM raster cell. The flow direction is calculated using the Rho8 
algorithm (Fairfield & Leymarie, 1991) and a single flow direction calculation to the 
steepest downslope neighbour. The Rho8 algorithm gives the advantage of fast 
calculation time and catches good the Norwegian topographical and metrological 
conditions, representing steep areas under high precipitation volume influence 
(López-Vicente, Pérez-Bielsa, López-Montero, Lambán, & Navas, 2014). 
 
To separate the high flow concentrations from the flow accumulation results, a 
threshold for the main flow paths is calculated. The root mean square flow 
accumulation is calculated according to Equation 1, considering all flow accumulation 
values: 
 𝑥ோெௌ = ටଵ௡ (𝑥ଵଶ +  𝑥ଶଶ + ⋯ +  𝑥௡ଶ)     (1) 

 
where xn is the flow accumulation value in grid cell n and xRMS is the root mean square 
used as flow accumulation threshold. Higher values are given larger weight by the 
RMS, due to the squaring of each value. This is necessary since there is many low 
values which are slightly higher than 1 (which is not of interest for the calculation) and 
only a few high values (of interests for the calculation). All cells with a higher flow 
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accumulation than the root mean square is defined as the Main Flow Paths. These 
paths represent a large connection of many flow paths, so in case of an overland flow, 
most of the runoff will follow these paths. This method gives a good overview of the 
runoff situation in a catchment to the accuracy necessary for the Decision-Support 
Method. 
 
2.2.3 High Potential SUDS Area Detection 
 
Potential SUDS Areas close to high surface runoff provide the opportunity to treat 
storm water effectively without the need of large drainage systems and/or intake 
infrastructure. Furthermore, if the elevation of the Potential SUDS Areas is equal or 
lower than the nearby runoff areas, it enables natural drainage and avoids costly 
modification of nearby terrain. Areas that fulfil these requirements are highly 
recommended for SUDS implementation and are therefore defined as High Potential 
SUDS Areas. 
 
 
2.3 Software 
 
The GIS analysis is performed by the open source program QGIS ® v. 2.18.13 with 
implementations from the open source program SAGA © GIS v. 2.3.2. The most used 
tools are the SAGA © GIS Modules "Slope, Aspect, Curvature" for terrain analysis 
and "Catchment Area (Flow Tracing)" for surface runoff detection. The output of the 
GIS analysis are several maps, that show urban planners Potential - and High 
Potential SUDS Areas, but also Main Flow Paths for surface runoff. Complete 
reference guidelines, including files of the developed tools to perform the described 
GIS analysis, can be downloaded from www.klima2050.no. 
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3 General Guideline Settings 
 
This GIS method was tested and works with the geo-information system program 
QGIS 2.18.13 64bit version for Windows. You can download it from: 
 
https://www.qgis.org/en/site/forusers/download.html  
 
Follow the installation instructions from QGIS User Guide » Chapter 6 Getting Started 
» 6.1 Installation (Athan, Blazek et al. 2018) 
 
The main objectives in this Guideline are using GIS tools which are included into the 
QGIS version 2.18.13. So, at the beginning of most of the working steps the used GIS 
tool is called, with its tool library, the tool name and the way to start the tool (see the 
example below). 
 

[Tool Library – Tool Name] 
(way » to » start) 
 
[QGIS – Merge Raster] 
(Menu bar » Raster » Miscellaneous » Merge) 
 

 
Another distinctive feature in this guideline are repeating steps. These instructions are 
given for steps which must be performed more than once, but with mainly the same 
settings. Repeating steps are shown by lists with small roman numbers in the 
settings (see example below). Repeat the step as often as there are orders (number 
of small roman numbers) in the list. 
  

I. Input Layer: 
 

i. "Raster 1 – digital terrain model (dtm)" 
 
ii. "Raster 2 – digital surface model (dsm)" 

 
II. Target CRS: Project CRS 

 
III. Uncheck rest settings 

 
IV. Output file:  

 
i. "Raster 3 – converted dtm raster" 
 
ii. "Raster 4 – converted dsm raster" 

 
 
In this example you have to repeat each step twice. Frist i.) with "Raster 1" as Input 
Layer and "Raster 3" as Output file and then ii.) with "Raster 2" as Input Layer 
and "Raster 4" as Output file. 
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4 Data Acquisition and Pre-processing 
 
 
 
Step 1 Define Coordination Reference System (CRS) 
 

1.1 Defining the Coordination Reference System for the GIS process at the 
beginning of the whole process, will prohibit transformation and editing 
errors. Selected Project CRS should be used for every data in the GIS 
process. 
 
[QGIS – Project Properties | CRS]  
(Menu Bar » Project » Project Properties » CRS) 

 
I. Open the Project Properties and enable 'on the fly' CRS transfor-

mation (OTF) 
 

This allows you to load data with different CRS into your GIS project 
without layout conflicts. Displays data in the project CRS, but just 
transforms the coordinates temporary. The original data coordinates 
will not be changed. This option is activated for easier display. 

 
 

 
Figure 3:  Example working sheet for CRS selection in [QGIS – Project Properties | CRS]. 
  



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 14 

II. Set the "Selected CRS" for the project. Search a CRS with the Filter 
and select the fitting one from the list (see Figure 3). 

 
Recommendation: use the relevant UTM zone at your project side. 
i.e.: ETRS89 / UTM zone N32 for Trondheim, Norway. For Norway, 
you can see a common zonal classification shown in Figure 4. 

 

 
Figure 4:  UTM zonal classification in Norway. 
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Step 2 Determine project extension and coordinates 
 

2.1 Get the minimum North and East Coordinate and the maximum North and 
East Coordinate. 

 
The minimum North and East and the maximum North and East 
coordinates of the project area will give the project extension (see Figure 
5b). For following process, you will need the coordinates in the following 
Coordination Reference Systems:  

 
WGS84: A global standard used coordinate system for mapping and 
navigation, i.e. used by Google Maps and Open Street Map. The map 
service hoydedata.no will also give you these coordinates. 

 
Project CRS, this should be the CRS you set in Step 1. Define 
Coordination Reference System (CRS), i.e.: ETRS89 – UTM 32N 

 
Recommendation: An easy way to obtain the coordinates in Norway is 
given by the map service www.hoydedata.no from the Norwegian 
Mapping Authority.  

 
I. Select the used CRS from your project (Step 1. Define Coordination 

Reference System (CRS)) in the menu bar on the website (see 
Figure 5a) 

 
II. Search for your project area via the search bar (see Figure 5a)  

 
III. You get the needed coordinates, by Left-Click on the relevant 

location at the map (see Figure 5b) in WGS84 CRS and in UTM 
coordinates selected in the website menu bar 

 
The UTM coordinates should be the same as the Project CRS from 
Step 1 
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Figure 5:  Example coordinate determination by the map service www.hoydedata.no, a) 

Menu bar of the website, b) map canvas of the website with highlighted extension 
points (right) and popped up coordinate window(left)  
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Step 3 Get input elevation data 
 

3.1 The digital terrain model (dtm) and digital surface model (dsm) of your 
project area are the most important input data for the GIS DSM. It is highly 
recommended to use raster size 1m x 1m.  

 
Recommendation: For most of Norway you can obtain this data by the 
map service www.hoydedata.no from the Norwegian Mapping Authority 
(green areas in Figure 6). Use the following procedure to obtain data from 
this site:  

 
I. Select UTM CRS in the menu bar 

 
II. Open Download tab 

 
III. Select area by "Enter corner coordinates" 

 
IV. Enter UTM coordinates from Step 2 (you will see the resulting map 

in the canvas) 
 

V. Choose product "Elevation model" 
 

VI. Choose type "National elevation model" 
 

VII. Choose data set: 
 

i. "DTM 1" for digital terrain model in raster size 1x1m 
 
ii. "DSM 1" for digital surface model in raster size 1x1m 

 
VIII. Project format "GeoTIFF" and Compression "LZ77" 

 
IX. Coordinate system and Compression "As dataset" 

 
X. Uncheck "Specify custom no-data value" 

 
XI. Prepare the order 

 
Give your email and a short description. You will get the data 
probably in the next few hours. 

 
i. "Raster 1 – digital terrain model (dtm)" 
 
ii. "Raster 2 – digital surface model (dsm)" 

 
You will get a much bigger raster file than your project area, because 
the map service will not cut their files to your project coordinates, 
but will sent you the original dtm or dsm files (normally 15 km x 15 
km raster squares). Also, you may get more than one raster file for 
the dtm or dsm, if your project area is on the border of these original 
dtm or dsm files. If you don’t get more than one file, pass to next 
GIS tool. 
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a) Figure 6: Elevation data availability in Norway for the green areas, by the map service 

www.hoydedata.no 

b) Figure 7: Example pop-up window for elevation data export from by the map service 
www.hoydedata.no 

 
 

3.2 Sometimes you get more than one raster files for your project area. Merge 
these separated raster files, so you can use one raster layer, which will 
simplify the coming processes. To do so, use [QGIS – Merge Raster] as 
following: 
 
[QGIS – Merge Raster] 
(Menu bar » Raster » Miscellaneous » Merge) 

 
I. Input files: 

 
i. All dtm raster files (.tif) 
 
ii. All dsm raster files (.tif) 

 
II. Uncheck all remaining settings 

 
III. Output file: 

 
i. New "Raster 1 – digital terrain model (dtm)" 
 
ii. New "Raster 2 – digital surface model (dsm)" 

  

a) b) 
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3.3 If you choose another CRS in Step 1 than the CRS which is used for your 

raster data (i.e. the elevation raster from www.hoydedata.no), you must 
convert your input raster data CRS to the project one. Also, if you choose 
the same CRS, it is recommended to translate the CRS anyway, because 
often the CRS is customised for such map services.   
 
Doing this for each Input Data will prohibit transformation and editing 
errors in the following process by using for all input data the same source 
code for the CRS. Use [GDAL – Translate (Convert format)] as following: 
 
[GDAL – Translate (Convert format)]  
(Menu bar » Raster » Conversion » Translate (Convert format)) 

 
I. Input Layer: 

 
i. "Raster 1 – digital terrain model (dtm)" 
 
ii. "Raster 2 – digital surface model (dsm)" 

 
II. Output file:  

 
i. "Raster 3 – converted dtm" 
 
ii. "Raster 4 – converted dsm" 

 
III. Target CRS: Project CRS 

 
IV. Uncheck rest settings 

 
  Figure 8: Exemplary working 

sheet for [GDAL – Translate 
(Convert format)] 
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Step 4 Get input buildings and infrastructure data 
 

4.1 Recommendation: Open Street Map gives good basic vector data for 
buildings and infrastructure. You can download this data directly from 
QGIS by using [QGIS – Download Open Street Map Data]. 
 
[QGIS – Download Open Street Map Data]  
(Menu bar » Vector » OpenStreetMap » Download Data…) 

 
I. Select "Manual" for extent definition 

 
II. Enter your WGS84 coordinates for the project extension (minimum 

North and East and maximum North and East coordinates) from 
Step 2, as seen in Figure 9 

 
III. Choose Output file direction 

 
IV. By pressing OK, the tool will download the data 

 
If no data has been downloaded this could mean a) the coordinates 
are wrong or b) no data for this area is available. In both cases make 
sure that your coordinates are right, i.e. via www.hoydedata.no. 

 
V. Output file: "OSM 1 – open street map data" 

 

 
Figure 9:  Example working sheet for [QGIS – Download Open Street Map Data]. 
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4.2 Add the vector data for buildings and infrastructure to the GIS project. 

Here the Open Street Map data is used for explanation, but this could be 
as well vector data from different sources. Use [QGIS – Add vector 
layer] as follow: 
 
[QGIS – Add vector layer] 
(Menu bar » Layer » Add vector layer…) 

 
I. Source type: File 

 
II. Encoding: System 

 
III. Press Browse » select "OSM 1 – open street map data" » press 

Open 
 

IV. Press Open » select "lines" and "multipolygons" » press OK 
 

V. Output files: "Vector 1 – OSM lines" and "Vector 2 – OSM 
multipolygons" 

 
The output files for OSM vector data is quite rough, like shown in 
Figure 10b, and will be edited in Step 6 
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Figure 10:  Example Open Street Map output, showing a) the project Layer Panel with 

"Vector 1 – OSM lines" and "Vector 2 – OSM multipolygons" and b) the 
appropriated map canvas. 

  

a) b) 
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4.3 As for the raster data, the vector data must be in the Project CRS as well. 

Doing this for each Input Data will prohibit transformation and editing 
errors in the following process by using for all input data the same source 
code for the CRS. Here the Open Street Map data is used for explanation, 
but this could be vector data from different sources. Use [GDAL – 
Translate (Convert format)] as following: 
 
[QGIS – Define current projection] 
(Menu bar » Vector » Data Management Tools » Define current projection) 

 
I. Input Layer: 

  
i. "Vector 1 – OSM lines" 
 
ii. "Vector 2 – OSM multipolygons" 

 
II. Output CRS: Project CRS 

 
This tool will not create a new file, but just overwrite the old one. 
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Step 5 Get orthophotos and background maps  
 

5.1 Orthophotos or background maps will be needed in a following step, to 
verify and complete the building and infrastructure data. Therefore, WMS 
server layers provide good opportunities, because these are often freely 
available. 

 
Recommendation: For most of Norway you can obtain WMS server layers 
by the map service http://kartkatalog.geonorge.no from the Norwegian 
Mapping Authority. To get WMS server layers, proceed as follow: 

 
I. Set Filter search on: » Distribution form » WMS-Service 

 
II. Search for a suitable Map data, i.e. by the community name 

 
Test several WMS Servers to find the needed maps (guidance, how 
to load into your GIS will following). Sometimes it is not clear from 
the description, what is given by the WMS-Server. I.e.: For 
Trondheim, the best suitable WMS-Server is the "DTM, DOM over 
Trondheim kommune" service. It is not clear from the title and the 
description, but this service also provides a background map and 
several orthophotos over Trondheim. 

 
III. Copy the "Get Capabilities URL" (see Figure 11) 

 

 
Figure 11:  Website layout of by the map service http://kartkatalog.geonorge.no and 

highlighted Capabilities URL. 
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5.2 To add the layers from the WMS Server to your GIS project, use [QGIS – 

Add Layer(s) from a WM(T)S Server]. 
 
[QGIS – Add Layer(s) from a WM(T)S Server] 
(Menu bar » Layer » Add WMS/WMTS Layer…) 

 
I. Press "New", open new window as seen in Figure 12b 

 
II. Paste the copied URL into the URL bar, name the WMS connection 

and press OK 
 

III. Leave the rest of the settings in the start window as Default 
 

IV. Select the new WMS connection in the pick list 
 

V. Press "Connect" 
 

VI. Select the wanted layer in the new layer pick list as seen in Figure 
12a, you can select more than one layer 

 
VII. Leave the rest of the settings as Default 

 
VIII. Press "Add" 

 
IX. Output Layer: "WMS Layer Map" 

 
You get one or more layers, which give a good overview about the 
project area, with buildings, streets, courtyards, etc. 

 
Figure 12:  Example working sheet for [QGIS – Add Layer(s) from a WM(T)S Server], a) start 

working sheet , b) working sheet to create new WMS connection.  
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Step 6 Add rough Open Street Map vector data 
 

6.1 The Open Street Map data is normally merged to just polygons or lines. 
In the following process you should filter the necessary vectors out of the 
data pool. Depending on the OSM input data, the used orders can be 
random. To get criteria to filter the vectors, analyse the attribute table of 
the vector data carefully (Right-Click "Vector 1 – OSM lines" or "Vector 2 
– OSM polygons" in the Layer Panel (see Figure 10a) » Attribute Table) 
Check the Attribute Table for fitting attributes which could classify possible 
buildings, land use or streets (see example attribute table in Figure 13). 

 
In the following GIS process are typical expressions called to extract data 
out. Depending on the OSM data there could be more and/or different 
selections. 

 
Figure 13:  Example Attribute Table for Open Street Map vector data. 

__________________________________________________________________________ 
 

6.2 The following shows an example to extract suitable vector data from OSM 
data, for: 

 
i. building vector 
 
ii. land use vector 

 
iii. (optional) street vector 

 
A street vector layer is for the GIS DSM not needed, but due to 
following data correction processes in Step 8 and afterwards to 
the DSM usage GIS post-processing, it is recommended to have 
knowledge about streets, too.  
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Use [QGIS – Extract by expression]. The used expressions are examples. 
In this guideline there will be always an explanation to the meaning of the 
expression. For a general explanation to the QGIS expression string 
building process and format rules, see QGIS Training Manual » 3 Module: 
Creating a Basic Map » Working with vector data » Expressions (Thiede, 
Sutton et al. 2018). 
 
[QGIS – Extract by expression]  
(Processing Toolbox » search for: Extract by expression) 

 
I. Input Layer: 

 
i. "Vector 2 – OSM polygons" 
 
ii. "Vector 2 – OSM polygons" 

 
iii. (optional) "Vector 1 – OSM lines" 

 
II. Expression: 

 
i. "building" IS NOT NULL 
 

i.e.: in the attribute table the column "building" indicates buildings 
by a simple "YES" or type indicator (see the attribute table in 
Figure 13). Any polygon which is not a building, gives no value in 
this field. The expression ' "building" IS NOT NULL ' indicates 
all fields with content in the column "building". See the results in 
Figure 14. 

 
ii. ("landuse" = 'grass' OR "landuse" = 'meadows' OR 

"landuse" = 'residential') AND "natural" IS NOT 'wood' 
 

i.e.: in the attribute table the column "landuse" shows if polygons 
have specific land use (see the attribute table in Figure 13). For 
areas with land use which enable SUDS application, we select 
"meadows" and "grass", but also in a wider view "residential" 
where in a following step we must remove the streets and private 
areas. Deal breaker for SUDS usage are mainly natural areas, 
where no constructions are allowed, like shown in the column 
"natural" with the indicator "wood". See the results in Figure 15. 

 
iii. (optional) "highway" IS NOT NULL 

 
i.e.: in the attribute table the column "highway" indicates streets 
by a type value (see Figure 23). Any line which is not a street, 
gives no value in this field. The expression ' "highway" IS NOT 
NULL ' indicates all fields with content in the column "highway". 
See the results in Figure 16. 

 
III. Extracted Output Layer: 

 
i. "Vector 3 – OSM buildings" 
 
ii. "Vector 4 – OSM landuse" 
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iii. (optional) "Vector 5 – OSM street lines" 
 
 

  
  

Figure 14:   Example Open Street Map output, showing "Vector 1 – OSM lines", "Vector 2 
– OSM multipolygons" and extracted " Vector 3 – OSM buildings" highlighted 
in red and b) appropriate working sheet for building extraction by [QGIS – 
Extract by expression]. 

 

 
  

Figure 15:  Example Open Street Map output, showing "Vector 1 – OSM lines", "Vector 
2 – OSM multipolygons" and extracted "Vector 4 – OSM landuse" highlighted 
in green and b) appropriate working sheet for landuse extraction by [QGIS – 
Extract by expression]. 

a)

b)

b)

a) 
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Figure 16:  Example Open Street Map output, showing a) "Vector 1 – OSM lines", "Vector 2 
– OSM multipolygons" and extracted " Vector 5 –street lines" highlighted via 
dotted lines and b) appropriate working sheet for street extraction by [QGIS – 
Extract by expression.  

a) 

b) 
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Step 7 Validate and correct Open Street Map vector data for buildings 
 

7.1 Because the Input data is based on the rough open source data from 
OSM, it could be possible that the data is not complete and accurate 
enough for the purpose of the decision support method. For "Vector 3 – 
OSM buildings" this could be inaccurate or not complete polygons (see 
Figure 17a) or total missing polygons (see Figure 17b). 

 

    
Figure 17:  Example of errors in the OSM building vector, showing red building polygon and 

a WMS orthophoto layer map in background, a) not complete drawn polygon, b) 
missing polygons. 

 
Recommendation: To find errors, it is recommended to use "WMS Layer 
Map" as background. In the Layer Panel, arrange "Vector 3 – OSM 
buildings" above the "WMS Layer Map" and make it transparency (Right-
Click "Vector 3 – OSM buildings" » Properties » Style » Transparency ≈ 
50%). 

  

b) a) 



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 31 

7.2 You can easily fix errors of the existing data by editing the polygons. To 
do so, active the Editing Mode for "Vector 3 – OSM buildings " and adjust 
the polygons. i.) Drag and drop nodes of a polygon to their right position, 
ii.) add new nodes to change the polygon form or iii.) delete existing 
nodes. You can do so, by: 

 
I. Enable "Vector 3 – OSM buildings" in the Layer Panel 

 
II. Digitizing Toolbar » Toggle Editing » Node Tool » Left-Click on the 

to edit polygon outline  
 

The outline and nodes of the polygon will be highlighted, like in 
Figure 18 
 

The Digitize Toolbar may not be visible, to enable it click Menu bar 
» View » Toolbars 

 
III. Correct "Vector 3 – OSM buildings" 

 
i. Move nodes: Left-Click on node » Drag and Drop to right position  
 
ii. Add node: Double-Left-Click on the outline 
 
iii. Remove node: Left-Click on the node » Press "Delete" key on 

keyboard 
 

Recommendation: A useful tool to fit polygons together is to enable 
the snipping option of QGIS (Menu bar » Settings » Snapping 
option). This will help to snap the edges of the different polygons 
together and prevent gaps or overlapping between the polygons. 
There are more useful tips for editing GIS features in the QGIS – 
Training Manual » 6. Module: creating Vector Data » 6. Lesson: 
Feature Topology (Thiede, Sutton et al. 2018). 

 
The results of the editing could look like the output in Figure 18a. 

 
IV. Save your edits (Digitizing Toolbar » Save layer edits) and disable 

the Editing Mode (Digitizing Toolbar » Toggle Editing) 

___________________________________________________________________ 
7.3 Add missing polygons as follow: 

 
I. Enable "Vector 3 – OSM buildings" in the Layer Panel 

 
II. Digitizing Toolbar » Toggle Editing » Add feature 

 
Add missing polygons by trace the streets from the "WMS Layer 
Map" in your map canvas like in Figure 18b 

 
III. Save your edits (Digitizing Toolbar » Save layer edits) and disable 

the Editing Mode (Digitizing Toolbar » Toggle Editing) 
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Figure 18  Example error correction for the OSM building vector, showing red building 

polygon and a WMS orthophoto layer map in background, a) correction for not 
complete drawn polygon, b) add missing polygons. 

___________________________________________________________________ 
 

7.4 After validation, editing and correction we get the final vector for buildings. 
Rename "Vector 3 – OSM buildings" to "Vector 7 – buildings". 

  

b) a) 
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Step 8 Validate and correct Open Street Map vector data for land use 
 

8.1 Because the Input data is based on the rough open source data from 
OSM, it could be possible that the data is not complete and accurate 
enough for the purpose of this project. "Vector 4 – OSM landuse" is mainly 
consisted of large, single polygons which do not consider buildings, 
courtyards or streets like seen in Figure 19. 

 
Recommendation: To find errors, it is recommended to use "WMS Layer 
Map" as background. In the Layer Panel, arrange "Vector 4 – OSM 
landuse" above the "WMS Layer Map" and make it transparency (Right-
Click "Vector 4 – OSM landuse" » Properties » Style » 
Transparency ≈ 50%). 
 
To fix errors we remove the already known polygons from "Vector 4 – 
OSM landuse" for SUDS application. Depending if you pass the street 
vectors or not, the following process will change a bit. 
 

    
Figure 19:  Example errors in the OSM building vector, showing green landuse polygon 

and a WMS orthophoto layer map in the background, showing not the correct 
outlines and overlapping streets, buildings and courtyards. 
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If you did not create "Vector 5 – OSM street lines" in Step 6, continue with Step 
8.2, otherwise go to Step 8.7 (p. 38)! 
 

8.2 Due to the original OSM data and the manual editing, there could be 
overlapping building polygons (see Figure 19). For a first correction, these 
areas can be removed via [QGIS – Difference]. 
 
[QGIS – Difference] 
(Menu bar » Vector » Geoprocessing tools » Difference) 
 
I. Input layer: "Vector 4 – OSM landuse" 

 
II. Difference layer: "Vector 7 – buildings" 

 
III. Output Difference Layer: "Vector 4_2 – tmp OSM landuse" 
 
If you get a process error due to invalid features, check the layers for 
topology errors like described in Step 11 (p. 45). 
 
The results could look something like Figure 22a. 
 

 
___________________________________________________________________ 
 

8.3 The remaining polygons in "Vector 4_2 – tmp OSM landuse" must now be 
edited manually. Depending on which areas you selected to be suitable 
for SUDS application, you must remove not suitable areas from 
"Vector 4_2 – tmp OSM landuse". This should be streets and could be 
courtyards and private garden areas (see in Figure 22b).  
 
Fix errors by editing the existing data. To do so, active the Editing Mode 
"Vector 4_2 – tmp OSM landuse" and cut off not suitable values. You can 
do so, by: 
 
I. Enable "Vector 4_2 – tmp OSM landuse" in the Layer Panel 

 
II. Digitizing Toolbar » Toggle Editing  

 
III. If the to cut off area don’t touch a polygon outline, use: 

 
i. 'Advanced Digitizing Toolbar » Add Ring' 

 
Trace the not suitable area, like in Figure 20 

 
 
If the to cut off area touch a polygon outline, use: 

 
ii. 'Advanced Digitizing Toolbar » Split Feature' and 'Advanced 

Digitizing Toolbar » Delete Part' 
 
Trace the not suitable area with a cutting line, begin and end at 
the outline of "Vector 4_2 – tmp OSM landuse". Also, you must 
cut a polygon completely, so no connections between the two 
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parts are existing (see Figure 21). Delete the resulting cut off part 
with "Delete Part". 
 
Tip: At trace ending, do not end exactly on the border line, but 
cross the border line with the cutting line (see trace ending in 
Figure 21). This avoids execution errors. 
 

 
If the Advanced Digitize Toolbar is not visible, enable it by clicking 
Menu bar » View » Toolbars 
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Figure 20  Example cut off via "Add ring" for the landuse vector correction, showing green 
landuse polygon, a WMS orthophoto layer map in background and the trace 
line in red, available if the cutting line doesn’t touch the outline. 

 

 

Figure 21  Example cut off via "Split feature" for the landuse vector correction, showing 
green landuse polygon, a WMS orthophoto layer map in background and the 
trace line in red, a) wrong tracing, the cutting line must cut off the polygon part 
completely, b) right tracing, if necessary follow an outline to cut off a complete 
part 

a) 

b) 
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___________________________________________________________________ 
 

8.4 Remaining errors can be fixed by editing the data. To do so, activate the 
Editing Mode for "Vector 4_2 – tmp OSM landuse" and adjust the 
polygons. i) Drag and drop nodes of a polygon to their right position, ii) 
add new nodes to change the polygon form or iii) delete existing nodes. 
You can do so, by repeating the Step 7.2 with "Vector 4_2 – tmp OSM 
landuse". 
 
The results of the editing could look something like Figure 22b. 

___________________________________________________________________ 
8.5 In the same way you find errors, you probably will find missing suitable 

landuse vectors for SUDS application, which are not implement into the 
OSM data. You can find these missing polygons in your "Vector 4_2 – tmp 
OSM landuse" also by using the "WMS Layer Map" as background. Add 
missing polygons by repeating the Step 7.3 with "Vector 4_2 – tmp OSM 
landuse". 

___________________________________________________________________ 
 

8.6 After validation, editing and correction you get the final vector for SUDS 
suitable landuses. Rename "Vector 4_2 – tmp OSM landuse" to "Vector 8 
– landuse". 
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If you did create "Vector 5 – OSM street lines" in Step 6, first go on with Step 9 
to Step 10 (p. 45) and continue with Step 8.7! 
 

8.7 Due to the original OSM data and the manual editing, there could be 
overlapping building and street polygons. For a first correction, 
overlapping areas from all vector layers can be removed via [QGIS – 
Difference]. 
 
[QGIS – Difference] 
(Menu bar » Vector » Geoprocessing tools » Difference) 
 
I. Input layer:  

 
i. "Vector 6_2 – tmp OSM streets" 

 
ii. "Vector 4 – OSM landuse" 

 
iii. "Vector 4_2 – tmp OSM landuse" 
 

II. Difference layer:  
 
i. "Vector 7 – buildings" 

 
ii. "Vector 7 – buildings" 

 
iii. "Vector 9 – streets" 

 
III. Output Difference Layer:  

 
i. "Vector 9 – streets" 

 
ii. "Vector 4_2 – tmp OSM landuse" 

 
iii. "Vector 4_3 – tmp OSM landuse" 

 
 
If you get a process error due to invalid features, check the layers for 
topology errors like described in Step 11 (p. 47). 
 
The results could look something like Figure 22a. 
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8.8 The remaining polygons in "Vector 4_3 – tmp OSM landuse" must now be 
edited manually. Depending on which areas you selected to be suitable 
for SUDS application, you must remove not suitable areas from "Vector 
4_3 – tmp OSM landuse". This should be streets and could be courtyards 
and private garden areas (see Figure 22b).  
 
Fix errors by editing the existing data. To do so, activate the Editing Mode 
"Vector 4_3 – tmp OSM landuse" and cut off not suitable values. You can 
do so, by: 
 
I. Enable "Vector 4_3 – tmp OSM landuse" in the Layer Panel 

 
II. Digitizing Toolbar » Toggle Editing  

 
III. If the to cut off area don’t touch a polygon outline, use: 

 
i. 'Advanced Digitizing Toolbar » Add Ring' 

 
Trace the not suitable area, like in Figure 20 

 
 
If the cut off area touch a polygon outline, use: 

 
ii. 'Advanced Digitizing Toolbar » Split Feature' and 'Advanced 

Digitizing Toolbar » Delete Part' 
 
Trace the not suitable area, begin and end at the outline of 
"Vector 4_3 – tmp OSM landuse". Also, you must cut a polygon 
completely, so no connections between the two parts are existing 
(see in Figure 21). Delete the resulting cut off part with "Delete 
Part". 
 
Tip: At trace ending, don’t end exactly on the border line, but 
cross the border line with the cutting line (see trace ending in 
Figure 21). This provides execution errors. 
 

If the Advanced Digitize Toolbar is not visible, enable it by clicking 
Menu bar » View » Toolbars. 

___________________________________________________________________ 
 

8.9 Remaining errors can be fixed by editing the data. To do so, active the 
Editing Mode for "Vector 4_3 – tmp OSM landuse" and adjust the 
polygons. i) Drag and drop nodes of a polygon to their right position, ii) 
add new nodes to change the polygon form or iii) delete existing nodes. 
You can do so, by repeating the Step 7.2 (p. 31) with "Vector 4_3 – tmp 
OSM landuse". 
 
The results of the editing could look something like Figure 22b. 
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Figure 22  Example error correction for the OSM street vector, showing the dotted OSM 

street lines, selected buffer polygon and adapting nodes in lilac and a WMS 
orthophoto layer map in background, a) correction for off-centre OSM street 
line, b) correction for validation errors due to the buffer creation in a crossing 
section. 

___________________________________________________________________ 
8.10 In the same way you find errors, you probably will find missing suitable 

landuse vectors for SUDS application, which are not implement into the 
OSM data. You can find these missing polygons in your "Vector 4_3 – tmp 
OSM landuse" also by using the "WMS Layer Map" as background. Add 
missing polygons by repeating the Step 7.3 (p. 31) with "Vector 4_3 – tmp 
OSM landuse". 

 
___________________________________________________________________ 

8.11 After validation, editing and correction we get the final vector for SUDS 
suitable landuses. Rename "Vector 4_3 – tmp OSM landuse" to "Vector 8 
– landuse". 

  

b) 

a) 
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Step 9 (optional) Modify Open Street Map vector data for streets 
 

9.1 The streets in OSM are just given by lines, but for further GIS work, 
polygons are more useful. Assuming that the lines are mainly in the middle 
of the streets and that the special street classes, see Figure 23, have 
mainly the same width, you can create buffer polygons around the lines 
to create simple street polygons. To do so, identify all "highway" classes 
and get representing street widths for them. Street widths can be detected 
by measure several widths with the help of the "WMS Layer Map" (Step 
5) and the QGIS measure tool (Menu bar » View » Measure » Measure 
Line). Do this for all "highway" classes. 

 
In this example, we do the whole procedure to determine the street width 
for the "highway" class "residential". Repeat the following for all "highway" 
classes. 

 
Figure 23:  Example Attribute Table for "Vector 5 – OSM street lines". 

__________________________________________________________________________ 
9.2 Add "Width" field to attribute table. 

 
[QGIS – Add Field] 

 
I. Right-Click "Vector 5 – OSM street lines" » Toggle Editing 

 
II. Right-Click "Vector 5 – OSM street lines" » Attribute table » Add 

field 
 

III. Name: Width 
 

IV. Field Type: Decimal number (real) 
 

V. Field length: 10 
 

VI. Field precision: 2 
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__________________________________________________________________________ 
9.3 Select all "residential" streets out of the data, see results in Figure 24. 

 
[QGIS – Select by expression] 

 
I. Right-Click "Vector 5 – OSM street lines" » Attribute table » Select 

feature using an expression 
 

II. Expression: "highway" = 'residential' 
 

  
  

Figure 24:  a) "residential highway" selection highlighted in yellow with WMS orthophoto 
layer map as background and b) appropriate working sheet for "residential" 
selection by expression. 

___________________________________________________________________ 
9.4 Add "Width" Attribute Values to "residential" selection from "Vector 5 – 

OSM street lines". 
 
[QGIS – Field calculator] 

 
I. Right-Click "Vector 5 – OSM street lines" » Attribute table » Open 

field calculator 
 

II. Check "Only 
update selected 
features" 

 
III. Check "Update 

existing field" 
 

IV. Select the field 
"Width" 

 
V. Expression: your 

determined width 
value in meter, i.e. 
4 

 

a) 

Figure 25: Exemplary work sheet for Attribute table
» Field calculator to add "Width" value 

b) 
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VI. By pressing "OK", all selected features will get the Width Attribute 
= 4  

___________________________________________________________________ 
9.5 Save you results by ' Right-Click "Vector 5 – OSM street lines" » Toggle 

Editing » Save changes ' and repeat this procedure for all available 
"highway" classes. 

___________________________________________________________________ 
9.6 To create the Buffer Polygon around the street lines, we need the Buffer 

Distance. This value is used as a radius value to create the buffer polygon 
around a line, with the line in the centre. Therefore, we must adjust the 
width value to the Buffer calculation, by dividing it in 2 via the Field 
calculator. 
 
[QGIS – Field calculator] 

 
I. Right-Click "Vector 5 – OSM street lines" » Attribute table » Open 

field calculator 
 

II. Uncheck "Only update selected features" 
 

III. Check "Create a new field" 
 

IV. Output field name: Buffer 
 

V. Field Type: 
Decimal number 
(real) 

 
VI. Field length: 10 

 
VII. Field precision: 2 

 
VIII. Expression: 

"Width" / 2  
 

this will divide all 
your "width" 
values with 2. 

 
IX. By pressing 

"OK", a new field 
will be created with 
Buffer Distance 
values 

  

Figure 26: Exemplary work sheet for Attribute table
» Field calculator to calculate "Buffer" value 
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___________________________________________________________________ 
9.7 Create a Street Polygon Vector, via [QGIS – Variable distance buffer]. 

 
[QGIS – Variable distance buffer]  
(Menu bar » Vector » Geoprocessing tools » Variable distance buffer) 

 
I. Input layer: "Vector 5 – OSM street lines" 

 
II. Distance field: Buffer 

 
III. Segments: 5 (default) 

 
IV. Check "Dissolve result" 

 
This will give one polygon for connected street lines and prevent 
overlapping. Eventual you want to cut the street polygons to 
separate parts later. Therefore use "Split feature" in the Editing 
Mode. 
 
See QGIS Training Manual » 3 Module: Creating a Basic Map » 
Working with vector data » Expressions (Thiede, Sutton et al. 2018) 
and QGIS – Training Manual » 6. Module: creating Vector Data » 6. 
Lesson: Feature Topology (Thiede, Sutton et al. 2018) for a detailed 
editing description. 

 
V. Output Buffer Layer: "Vector 6 – OSM street polygons" 
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Step 10 (optional) Validate and correct Open Street Map vector data for 
streets 

 
10.1 Because the Input data is based on the rough open source data from 

OSM, it could be possible that the data is not complete and accurate 
enough for the purpose of this project. For "Vector 6 – OSM street 
polygons" this could be off-centre OSM street lines (see Figure 27a) or 
validation errors due to the buffer creation, like in crossing sections (see 
Figure 27b). 

 

 

 
Figure 27:  Example errors in the OSM street vector, showing the dotted OSM street lines, 

blue buffer polygon and a WMS orthophoto layer map in background, a) off-centre 
OSM street line, b) validation errors due to the buffer creation in a crossing 
section. 

 
Recommendation: To find errors, it is recommended to use "WMS Layer 
Map" as background. In the Layer Panel, arrange "Vector 5 – OSM street 
lines" and "Vector 6 – OSM street polygons" above the "WMS Layer Map" 
and make "Vector 6 – OSM street polygons" transparency (Right-Click 
"Vector 6 – OSM street polygons" » Properties » Style » Transparency ≈ 
50%) 

  

b) a) 
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___________________________________________________________________ 
10.2 You can easily fix errors by editing the existing data. To do so, active the 

Editing Mode for "Vector 6 – OSM street polygons " and adjust the 
polygons. i) Drag and drop nodes of a polygon to their right position, ii) 
add new nodes to change the polygon form or iii) delete existing nodes. 
You can do so, by repeating the Step 7.2 (p. 31) for "Vector 6 – OSM 
street polygons ". 
 
The results of the editing could look something like Figure 28. 
 

 

 
Figure 28  Example error correction for the OSM street vector, showing the dotted OSM 

street lines, selected buffer polygon and adapting nodes in lilac and a WMS 
orthophoto layer map in background, a) correction for off-centre OSM street 
line, b) correction for validation errors due to the buffer creation in a crossing 
section. 

___________________________________________________________________ 

10.3 In the same way you find errors, you probably will find missing streets, 
which are not implemented into the OSM data. You can find these missing 
polygons in your "Vector 6 – OSM street polygons " also by using the 
"WMS Layer Map" as background. Add missing polygons by repeating the 
Step 7.3 (p. 31) for "Vector 6 – OSM street polygons ". 

___________________________________________________________________ 
10.4 After validation, editing and correction we get a temporarily used vector 

for streets. Rename "Vector 6 – OSM street polygons" to "Vector 6_2 – 
tmp OSM streets". 
 
The final adjustment to "Vector 9 – streets" will be done in Step 8.7. 
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Continue with Step 8.7 (p. 38) 

 
Step 11 Check features for topology errors 
 

11.1 Due to the complex adjustment process for all final Vectors: "Vector 7 – 
buildings", "Vector 8 – landuse" and (optional) "Vector 9 – streets", there 
is the possibility for topological errors. With the [QGIS – Topology 
Checker] you can localise most of the errors in your data. 
 
[QGIS – Topology Checker] 
(install manually) 
 
I. Menu bar » Plugins » Manage and Install Plugins… 

 
II. Search for "Topology Checker" 

 
III. Check Plugin 

 
IV. Menu bar » Vector » Topology Checker  

 
This will open a new Topology Checker Panel, looking something 
like Figure 29a. 

 
V. Open the "Topology Rule Settings" (see Figure 29a) 

 
VI. Add rules like ' "Vector 8 – landuse" must not overlap with "Vector 7 

– buildings" ' or ' "Vector 8 – landuse" must not have invalid 
geometries ' and alike, which could show errors in all of your final 
Vectors: "Vector 7 – buildings", "Vector 8 – landuse" and (optional) 
"Vector 9 – streets". 

 
Resulting settings could look something like Figure 29b. 

 
VII. Validate all 

 
By validate the layer, you will see areas with errors, like the one you 
defined before.  

     



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 48 

  

 
Figure 29:  a) The Topology Checker Panel with button explanation and b) example 

working sheet for the Topology Rule Settings. 
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___________________________________________________________________ 
11.2 Adjust the errors. Use the same methods as described in step 7.2 (p. 31) 

for error correction.  
 
If you have invalid geometries, this could often be caused by: 
 
The outlines of a polygon cross each other 
 
I. Re-adjust the nodes, so the outlines do not cross each other 

 
 

Or two nodes have the same coordinates  
 
I. Delete one of the nodes 
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Step 12 Create catchment area vector 
 

12.1 Create a new catchment area vector shapefile. This vector will 
summarize the whole catchment area, including all final vector data. 
Create the new file with [QGIS –  Create shapefile layer]. 
 
[QGIS –  Create shapefile layer] 
(Menu bar » Layer » Create Layer » Create shapefile layer) 
 
I. Type: Polygon 

 
II. CRS: Project CRS 

 
III. The other settings as Default 

 
IV. Output: "Vector 10 – catchment area" 

___________________________________________________________________ 
12.2 The catchment area will be one polygon and should include all runoff 

areas inside the project area. Also, all possible areas for SUDS 
construction within the project area must be inside the catchment area. 
This file should have the same extensions as defined in Step 2. An 
example how this could look like can be found in Figure 5. You can use 
the "WMS Layer Map" as background. Draw the catchment area polygon 
for your project in Editing mode. 
 
I. Enable "Vector 10 – catchment area" in the Layer Panel 

 
II. Digitizing Toolbar » Toggle Editing » Add feature 

 
III. Draw the catchment area polygon for your project in the map 

canvas.  
 

IV. Save your edits (Digitizing Toolbar » Save layer edits) and disable 
the Editing Mode (Digitizing Toolbar » Toggle Editing) 
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5 SUDS Area Detection Algorithm – Step by step 
 
The following steps give a stepwise in-depth description of all used QGIS tools to 
create the Potential SUDS Areas, Main Flow Paths and High Potential SUDS Areas.  
As in the chapter before it is required to use the same coordination reference 
system (CRS) for all input data. See Chapter 2 how to set the CRS. 
 
Step 1 Adjust Raster Input 
 

1.1 Modify the original raster to the necessary catchment area, to save 
storage volume and calculation time, by [GDAL – Clip raster by mask 
layer]. 
 
[GDAL – Clip raster by mask layer] 
(Processing Toolbox » search for: Clip raster by mask layer) 
 
I. Input layer: 

 
i. "Raster 3 – converted dtm" 

 
ii. "Raster 4 – converted dsm"  

 
II. Mask layer: "Vector 10 – catchment area" 

 
III. Check "Crop the extent of the target dataset to the extent of the 

cutline" 
 

IV. Check "Keep resolution of output raster" 
 

V. Rest setting as Default 
 

VI. Output – Clipped (mask): 
 

i. "Raster 5 – dtm 
clipped" 
 

ii. "Raster 6 – dsm 
clipped" 
 

 
  

Figure 30: Example working sheet for [GDAL –
Clip raster by mask layer]. 
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Step 2 Determine Land Use Raster 
 

2.1 Create template raster with the same size and resolution as the clipped 
Catchment Raster with i.) all cell values = 0 and ii.) all cell values = 1. 
These rasters are necessary for following GIS processes. 
 
[SAGA – Reclassify values]  
(Processing Toolbox » search for: Reclassify values) 

 
I. Input – Grid: "Raster 5 – dtm clipped" 

 
II. Method: Single 

 
III. Old value (for single value change): -32767 ("no 

data" value in QGIS) 
 

IV. New value (for single value change):  
 

i. 0 
 

ii. 1 
 

V. Operator (for single value change): >=  
 

VI. Uncheck "replace no data values" 
 

VII. Uncheck "replace other values" 
 

VIII. Rest settings as Default 
 

IX. Output – Reclassified Grid: 
 

i. "Raster 7 – template zero" 
 

ii. "Raster 8 – template one" 
 

  

Figure 31: Example working 
sheet for [SAGA – Reclassify 
values]. 
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___________________________________________________________________ 

2.2 Add new attributes to the Vector Data imported in the pre-processing part 
that will be used to create new raster files to represent buildings, terrain 
and landuse suitable for SUDS application. Use therefore the [QGIS – 
Field calculator]. 
 
[QGIS – Field calculator] 

 
I. Right-Click: 

 
i. "Vector 7 – buildings" » Attribute table » Open field calculator 

 
ii. "Vector 7 – buildings" » Attribute table » Open field calculator 

 
iii. "Vector 8 – landuse" » Attribute table » Open field calculator 

 
II. Check "Create a new field" 

 
III. Output field name: 

 
i. One 

 
ii. Zero 

 
iii. One 

 
IV. Output field type: Decimal 

number (real) 
 

V. Field length: 10 
 

VI. Field precision: 3 
 

VII. Expression: 
 

i. 1 
 

ii. 0 
 

iii. 1 
 

VIII. By pressing "OK", a new field will be created with the "Expression" 
value 
 

IX. Save the edits (Digitizing Toolbar » Save layer edits) and disable 
the Editing Mode (Digitizing Toolbar » Toggle Editing) 
 

 
  

Figure 32: Example working sheet 
for [QGIS – Field calculator]. 
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___________________________________________________________________ 

2.3 Write the added attributes from the vector data from Step 2.2 over the 
raster templates from Step 0. This will give raster for following purposes: 
 

i. A raster which shows the building roof area by a cell value = 1, 
rest of the cell values = 0.  
 

ii. A raster which shows terrain by a cell value = 1, rest of the cells 
are all building roofs and have a cell value = 0. We use this raster 
to create an elevation raster with different values for terrain cells 
and building cells in Step 3 (p. 56). The flow accumulation in Step 
6 (p. 62) also will be calculated only for the terrain. 

 
iii. A raster which shows the landuse for SUDS applications by a cell 

value = 1, rest cell values = 0. This is used in the Potential SUDS 
Area Detection in Step 5 (p. 60).   

 
Use therefore [GDAL – Rasterize (vector to raster)]. 
 
[GDAL – Rasterize (vector to raster)] 
(Menu bar » Raster » Rasterize (Vector to raster)) 
 
II. Input file (shapefile):  

 
i. "Vector 7 – buildings"  

 
ii. "Vector 7 – buildings" 

 
iii. "Vector 8 – landuse" 

 
III. Attribute field: 

 
i. One 

 
ii. Zero 

 
iii. One 

 
IV. Output file for rasterized vectors (raster):  

 
This will override any existing raster. Copy the template raster 
before, rename them and choose these copies as output. Do as 
followed: 
 
i. copy "Raster 7 – template zero" » rename Copy "Raster 7 – 

template zero" to "Raster 9 – pointing out building area" » select 
"Raster 9 – pointing out building" as output file 
 

ii. copy "Raster 8 – template one" » rename Copy "Raster 8 – 
template one " to "Raster 10 – pointing out terrain" » select 
"Raster 10 – pointing out terrain" as output file 
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iii. copy "Raster 7 – template zero" » rename Copy "Raster 7 – 
template zero" to "Raster 11 – pointing out land use" » select 
"Raster 11 – pointing out landuse" as output file 

 
V. Check "Keep existing raster size and resolution" 

 

 
Figure 33:  Example working sheet for [GDAL – Rasterize (vector to raster)] 
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Step 3 Create Combined Elevation Model 
 

3.1 Fill local depressions in terrain to ensure uninterrupted flow lines in the 
flow accumulation calculation. 
 
[SAGA – Fill sinks xxl (Wang & Liu)] 
(Processing Toolbox » search for: Fill sinks xxl) 
 
I. Input – DEM: "Raster 5 – dtm clipped" 

 
II. Minimum Slope [Degree]:  0,010 

 
III. Output – Filled DEM: "Raster 12 – dtm filled" 

 
 
___________________________________________________________________ 

3.2 Create the combined elevation model by merging information from 
different raster data. For the ground surface we use the filled dtm raster 
and buildings get elevation values from the dsm. By doing this we get an 
elevation model, as close to the reality as needed for our purpose. In Step 
6 (p. 62) the flow accumulation will be calculated just for the ground 
surface. The runoff is not allowed to cross buildings. We use the real 
elevation values for buildings as a flow blockade, like it would be in reality.  
 
Use the [QGIS – Raster Calculator] with data from "Raster 6 – dsm 
clipped", "Raster 12 – dtm filled" and "Raster 10 – pointing out terrain". 
 
[QGIS – Raster Calculator]  
(Menu bar » Raster » Raster Calculator) 

 
I. Raster calculator expression:  

 
(("Raster 10 – pointing out terrain" = 0) * "Raster 6 – dsm clipped") 
+ (("Raster 10 – pointing out terrain" = 1) * "Raster 12 – dtm filled")  
 
By this expression there will be a new raster with the values for 
buildings from the dsm and for the rest of the values from the filled 
dtm. 
 

II. Set layer extent to catchment layer extent by selecting "Raster 6 – 
dsm clipped" and pressing "Current layer extent" button 

 
III. Output CRS: Project CRS 

 
IV. Output layer: "Raster 13 – combined elevation model" 
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Figure 34:  Example working sheet for [QGIS – Raster calculator]. 
 
___________________________________________________________________ 

3.3 Modify the original raster to the necessary catchment area, to save 
storage volume and calculation time. 
 
[GDAL – Clip raster by mask layer] 
(Processing Toolbox » search for: Clip raster by mask layer) 

 
I. Input layer: "Raster 13 – combined elevation model" 

 
II. Mask layer: "Vector 10 – catchment area" 

 
III. Check "Crop the extent of the target dataset to the extent of the 

cutline" 
 

IV. Check "Keep resolution of output raster" 
 

V. Rest setting as Default 
 

VI. Output – Clipped (mask): "Raster 14 – combined elevation model 
clipped"  
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Step 4 Calculate Surface Slope  
 

4.1 Calculate the slope for just the terrain with [SAGA – Slope, aspect, 
curvature], based on the dtm raster. Slopes for building roofs are not 
needed. Ignore the rest of the calculation possibilities in this tool. 
 
[SAGA – Slope, aspect, curvature] 
(Processing Toolbox » search for: Slope, aspect, curvature) 

 
I. Input – Elevation: "Raster 5 – dtm clipped" 

 
II. Method: 9 parameter 2nd order polynom (Zevenbergen & Thorne 

1987) 
 

III. Slope Units: percent 
 

IV. Output – Slope: "Raster 15 – slope" 
 

 
Figure 35:  Example working sheet for [SAGA – Slope, aspect, curvature]. 

  

ignore 
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___________________________________________________________________ 

4.2 Modify the slope raster to the necessary catchment area. 
 
[GDAL – Clip raster by mask layer] 
(Processing Toolbox » search for: Clip raster by mask layer) 

 
I. Input layer: "Raster 15 – slope" 

 
II. Mask layer: "Vector 10 – catchment area" 

 
III. Check "Crop the extent of the target dataset to the extent of the 

cutline" 
 

IV. Check "Keep resolution of output raster" 
 

V. Rest setting as Default 
 

VI. Output – Clipped (mask): "Raster 16 – slope clipped" 

 
___________________________________________________________________ 

4.3 Create raster which shows areas with low slope (<10%) by the cell value 
1. 
 
[SAGA – Reclassify values]  
(Processing Toolbox » search for: Reclassify values) 

 
I. Input – Grid: "Raster 16 – slope clipped" 

 
II. Method: Single 

 
III. Old value (for single value change): 10 

 
IV. New value (for single value change): 1 

 
V. Operator (for single value change): <=  

 
VI. Uncheck "replace no data values" 

 
VII. Check "replace other values" 

 
VIII. New value for other values: 0 

 
IX. Rest settings as Default 

 
X. Output – Reclassified Grid: "Raster 17 – low slope area" 
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Step 5 Determine Potential SUDS Areas 
___________________________________________________________________ 

5.1 Create the Result Raster for Potential SUDS Areas by merging 
information from different raster data using calculation expression [QGIS 
– Raster Calculator] with data from "Raster 11 – pointing out landuse" and 
"Raster 17 – low slope area". 
 
[QGIS – Raster Calculator]  
(Menu bar » Raster » Raster Calculator) 

 
I. Raster calculator expression:  

 
"Raster 11 – pointing out landuse" * "Raster 17 – low slope area" 

 
By this expression there will be created a new raster which shows 
landuse suitable to SUDS applications with low slope, because: 
 
in Raster 11 value for landuse = 1 and for rest = 0, 
 
in Raster 17 value for areas with low slope = 1 and for rest = 0 
 
and in new "Result Raster 1", landuse suitable to SUDS applications 
with low slope will have value = 1 (1*1=1), rest = 0 

 
II. Set layer extent to catchment layer extent by selecting "Raster 11 – 

pointing out landuse" and pressing "Current layer extent" button 
 

III. Output CRS: Project CRS 
 

IV. Output layer: "Result Raster 1 – Potential SUDS Area" 
 

 
Figure 36:  Example working sheet for [QGIS – Raster Calculator]. 
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___________________________________________________________________ 

5.2 Convert the raster to separated polygons, which can be used in an post-
processing GIS analyse. 
 
[QGIS – Polygonize (Raster to vector)] 
(Menu bar » Raster » Conversion » Polygonize (Raster to vector)) 

 
I. Input file: "Result Raster 1 – Potential SUDS Area" 

 
II. Output file for polygons (shapefile): "Result Vector 1 – Potential 

SUDS Area" 
 

III. Field name: DN 
 

___________________________________________________________________ 
5.3 The created polygons may have a few topology errors, which could cause 

calculation errors. Step 9 (p. 74) describes some methods to check and 
correct the polygons. 
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Step 6 Calculate Flow Accumulation 
 

6.1 Calculate the flow accumulation on the ground surface, based on a flow 
tracing algorithm. Runoff from buildings is not considered in this 
calculation. 
 
[SAGA – Catchment area (flow tracing)] 
(Processing Toolbox » search for: Catchment area (flow tracing)) 

 
I. Input – Elevation: "Raster 14 – combined elevation model clipped" 

 
By using the combined elevation model, we can calculate the flow 
accumulation on the ground with the elevation values from the dtm 
and block flow across buildings due to elevation values for building 
from the dsm. 

 
II. Input – Weights:  

"Raster 10 – pointing out 
terrain" 
 
The weight in this tool show 
which cell gives which 
amount of runoff. Because 
we just want to calculate 
ground surface runoff, just 
terrain cells give runoff. In 
the pointing out terrain 
raster, all terrain cells have 
the value 1 and buildings 
have the value 0, which 
result in no runoff from 
building roofs. 

 
III. Flow Accumulation Units:

 Cell Area 
 

IV. Step: 1 
 

V. Method: Rho 8 
 

The Rho8 algorithm has the 
advantage of a fast 
calculation time. Other 
methods could also be used 
if it fits better to the project. 
Due to the Norwegian 
topographical and 
metrological conditions, the 
Rho8 algorithm gives good 
results to steep areas under 
high precipitation volume 
influence (López-Vicente, Pérez-Bielsa et al. 2014). 

 

Figure 37: Example working sheet for
[SAGA – Catchment area (flow
tracing)]. 
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VI. Output – Flow Accumulation:  
"Raster 18 – flow accumulation" 

 
VII. Uncheck rest settings 

___________________________________________________________________ 

6.2 Transform the raster values from flow accumulation raster to points. We 
use this method to create a link layer between raster and vector data. 
Also, it is much easier to calculate using vector points instead of raster 
cells, including the possibility to just edit a few points and ignore the rest. 
The points reside in the cell-centre and get the cell value (flow 
accumulation) as an attribute named "VALUE". 
 
[SAGA – Raster values to points (randomly)]  
(Processing Toolbox » search for: Raster values to points) 

 
I. Input – Grid: "Raster 18 – flow accumulation" 

 
II. Frequency:  1 (create a point in each cell) 

 
III. Output – Points: "Vector 11 – flow accumulation points" 

 
___________________________________________________________________ 

6.3 Extract point vectors out of the flow accumulation points, which have a 
value greater 0. Cells with no data or 0 would falsify the Root Mean 
Square calculation of all flow accumulation values in the next Step. 
 
[QGIS – Extract by expression]  
(Processing Toolbox » search for: Extract by expression) 
 
I. Input Layer: "Vector 11 – flow accumulation points" 

 
II. Expression: "Value" >= 0 

 
III. Extracted Output Layer: "Vector 12 – flow accumulation points 

selected" 
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Step 7 Determine Main Flow Paths 
 

7.1 Extract point vectors out of the flow accumulation points, which have a 
value greater than the Root Mean Square (RMS). The remaining points 
show the Main Flow Paths. We choose the RMS as separator, because 
in the data there are expected to be many low values which are slightly 
higher than 1 and only a few high values. The RMS grade higher values 
stronger, due to the squaring of each value and gives so a mean value for 
high flow accumulation. 
 
[QGIS – Extract by expression]  
(Processing Toolbox » search for: Extract by expression) 
 
I. Input Layer: "Vector 12 – flow accumulation points selected" 

 
II. Expression: "VALUE" >= 

sqrt(sum(("VALUE"^2))/count("VALUE">0)) 
 

III. Extracted Output Layer: "Vector 13 – Main Flow Path points" 
 

 

 

Figure 38:  Example working sheet for [QGIS – Extract by expression]. 
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___________________________________________________________________ 
7.2 Add new attribute = 1 to the Main Flow Path points which will be used to 

create the Result Raster files to represent the Main Flow Path. 
 
[QGIS – Field calculator] 

 
I. Right-Click: "Vector 13 – Main Flow Path points" 
 

II. Check "Create a new field" 
 

III. Output field name: One 
 

IV. Output field type: Decimal number (real) 
 

V. Field length: 10 
 

VI. Field precision: 3 
 

VII. Expression: 1 
 

VIII. By pressing "OK", a new field will be created with the "Expression" 
value 

 
IX. Save the edits (Digitizing Toolbar » Save layer edits) and disable 

the Editing Mode (Digitizing Toolbar » Toggle Editing) 
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___________________________________________________________________ 

7.3 Create the "Result Raster 2 – Main Flow Path" out of the Main Flow Path 
points. Therefore, the attribute "One" (which is for every point 1) from Main 
Flow Path points will be written over a raster template with cell values = 
0. 
 
[GDAL – Rasterize (vector to raster)]  
(Menu bar » Raster » Conversation » Rasterize (vector to raster)) 
 
I. Input file (shapefile): "Vector 13 – Main Flow Path points" 

 
II. Attribute field: "One" 

 
III. Output file for rasterized vectors (raster): 

 
This will override an existing raster. Copy the template raster before, 
rename them and choose these copies as output. Do as followed: 
 
Copy "Raster 7 – template zero" » rename Copy "Raster 7 – 
template zero" to "Result Raster 2 – Main Flow Path" » select 
"Result Raster 2 – Main Flow Path" as output file 
 

IV. Check "Keep existing raster size and resolution" 
 

To see the resulting Main Flow Paths in the map canvas, you must change 
the style by give a display min value = 0 and max value = 1. 
 
(Right-Click: "Result Raster 2 – Main Flow Path" » Properties » Style) 
 
More useful tips to modify the raster style can be found in QGIS Training 
Manual » 8. Module: Raster » 8.2. Lesson: Changing Raster 
Symbiology(Thiede, Sutton et al. 2018). 
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Step 8 Determine High Potential SUDS Area 
 

8.1 To determine the High Potential SUDS Areas, we will work with the 
created point vectors. These points need additional attribute values from 
further raster. To get these attributes, the [Point Sampling Tool] plugin by 
Borys Jurgiel is highly recommended (see Figure 39 for plugin 
description). 
 
[Point Sampling Tool] by Borys Jurgiel 
(install manually) 
 
I. Menu bar » Plugins » Manage and Install Plugins… 

 
II. Search for "Point Sampling Tool" 

 
III. Install plugin 

 
Figure 39:  Working sheet to install the [Point Sampling Tool] plugin by Borys Jurgiel. 
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___________________________________________________________________ 

8.2 Get additional elevation and Potential SUDS Area attributes to point 
vectors from "Raster 5 – dtm clipped" and "Result Raster 1 – Potential 
SUDS Area". Use [Plugin Sampling Tool] by Borys Jurgiel. 
 
[Plugin Sampling Tool] by Borys Jurgiel 
(Menu bar » Plugins » Analyses » Point Sampling Tool) 

 
I. Layer containing sampling points: 

 
i. "Vector 12 – flow accumulation points selected" 

 
ii. " Vector 13 – Main Flow Path points" 

 
II. Layers with field/bands to get values from: 

 
More than one selection possible 
 
i. "Raster 5 – dtm clipped" and "Result Raster 1 – Potential SUDS 

Area" 
 

ii. "Raster 5 – dtm clipped" 
 

III. Output point vector layer: 
 
i. "Vector 14 – Potential SUDS Area points" 

 
ii. "Vector 15 – Main Flow Path points with elevation" 

 

 
Figure 40:  Example working sheet for the [Point Sampling Tool] plugin by Borys Jurgiel. 
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___________________________________________________________________ 
8.3 Extract point vectors out of the Potential SUDS Area points, which have 

the attribute "Potential SUDS Area VALUE" = 1. This attribute was added 
to the "Vector 14 – Potential SUDS Area points" in the previous step by 
the "Result Raster 1 – Potential SUDS Area" (A description what "VALUE" 
in the raster describe is given in Step 5.1 (p. 60)). 
 
[QGIS – Extract by attribute]  
(Processing Toolbox » search for: Extract by expression) 
 
I. Input Layer: "Vector 14 – Potential SUDS Area points" 

 
II. Selection attribute: Potential SUDS Area VALUE  

 
[Plugin Sampling Tool] will cut the attribute name to 10 characters, 
so the real attribute name will be i.e. just "Potential " like in Figure 
41 
 

III. Operator: = 
 

IV. Value: 1 
 

V. Extracted - Output Layer: "Vector 16 – selected Potential SUDS 
Area points" 

 

 
Figure 41:  Example working sheet for [QGIS – Extract by attribute]. 
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___________________________________________________________________ 

8.4 Calculate the distance between "Vector 16 – selected Potential SUDS 
Area points" and "Vector 15 – Main Flow Path points with elevation". Also 
[QGIS – Distance to nearest hub] adds attribute information from the 
nearest hub point to the related source point. The source point layer will 
be "Vector 16 – selected Potential SUDS Area points" and hub layer will 
be "Vector 15 – Main Flow Path points with elevation". By selecting 
elevation information as the add hub layer attribute, the Potential SUDS 
Area points will get the elevation of the nearest Main Flow Path point. 
 
[QGIS – Distance to nearest hub]  
(Processing Toolbox » search for: Distance to nearest hub) 
  
I. Input – Source point layer: "Vector 16 – selected Potential SUDS 

Area points" 
 

II. Destination hubs layer: "Vector 15 – Main Flow Path points with 
elevation" 
 

III. Hub layer name attribute: dtm raster clipped VALUE  
 

This is the elevation data from "Raster 5 – dtm clipped". This 
attribute was added to the "Vector 15 – Main Flow Path points with 
elevation" in the Step 8.2 (p. 68). 
 
[Plugin Sampling Tool] will 
cut the attribute name to 10 
characters, so the real 
attribute name will be i.e. 
just "dtm raster" like in 
Figure 42 

 
IV. Output shape type: Point 

 
V. Measurement unit:  Meter 

 
VI. Output – Hub distance: 

"Vector 17 – Potential 
SUDS Area points with hub 
dist and elev" 

  

Figure 42: Example working sheet for 
[QGIS – Distance to nearest hub]. 
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___________________________________________________________________ 

8.5 Extract point vectors out of the Potential SUDS Area points where the 
elevation of the Potential SUDS Area point is lower or equal than the 
elevation of the nearest Main Flow Path point, given to the vector as hub 
information in the previous step. This is the first step to get the High 
Potential SUDS Area points. 
 
[QGIS – Extract by expression]  
(Processing Toolbox » search for: Extract by expression) 
 
I. Input Layer: "Vector 17 – Potential SUDS Area points with hub dist 

and elev" 
 

II. Expression: "dtm raster clipped VALUE" <= "HubName" 
 

"dtm raster clipped VALUE": own Elevation data of the Potential 
SUDS Area points. [Plugin Sampling Tool] in previous Step 8.2 will 
cut the attribute name to 10 characters, so the real attribute name 
will be i.e. just "dtm raster". 
 
"HubName": Hub attribute, the elevation of the nearest Main Flow 
Path point. The attribute name "HubName" will be generated 
automatically. 
 
Check the real attribute names in the attribute table of "Vector 18 – 
Potential SUDS Area points with hub dist and elev", before you give 
the expression. 
 

III. Extracted Output Layer: "Vector 18 – lower Potential SUDS Area 
points" 

  



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 72 

___________________________________________________________________ 

8.6 Extract point vectors out of the lower Potential SUDS Area points which 
are close to the nearest Main Flow Path point. The distance attribute is 
given to the Potential SUDS Area points in Step 8.4. This is the final step 
to get the High Potential SUDS Area points. 
 
[QGIS – Extract by attribute]  
(Processing Toolbox » search for: Extract by expression) 
 
I. Define a threshold for the distance to the next Main Flow Path. A 

recommended value is 100 m. 
 

II. Input Layer: "Vector 18 – lower Potential SUDS Area points " 
 

III. Selection attribute: HubDist 
 

"HubDist": Hub distance, the distance to the nearest Main Flow Path 
point. The attribute name "HubDist" will be generated automatically. 
 

IV. Operator: <= 
 

V. Value: defined threshold, i.e.: 100 
 

VI. Extracted - Output Layer: "Vector 19 – High Potential SUDS Area 
points" 
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___________________________________________________________________ 

8.7 Create the "Result Raster 3 – High Potential SUDS Area" out of the High 
Potential SUDS Area points. Therefore, the attribute "Potential SUDS 
Area VALUE" (which for every point is 1) from High Potential SUDS Area 
points will be written over a raster template with cell values = 0. 
 
[GDAL – Rasterize (vector to raster)]  
(Menu bar » Raster » Conversation » Rasterize (vector to raster)) 
 
I. Input file (shapefile): "Vector 19 – High Potential SUDS Area points" 

 
II. Attribute field: "Potential SUDS Area VALUE" 

 
[Plugin Sampling Tool] in previous Step 8.2 will cut the attribute 
name to 10 characters, so the real attribute name will be i.e. just 
"Potential " 
 

III. Output file for rasterized vectors (raster): 
 

This will override an existing raster. Copy the template raster before, 
rename them and choose these copies as output. Do so as followed: 
 
copy "Raster 7 – template zero" » rename Copy "Raster 7 – 
template zero" to "Result Raster 3 – High Potential SUDS Area" » 
select "Result Raster 3 – High Potential SUDS Area" as output file 
 

IV. Check "Keep existing raster size and resolution" 
 

___________________________________________________________________ 

8.8 Convert the "Result Raster 3 – High Potential SUDS Area" to separated 
polygons, which can be used in a post-processing GIS analyse. 
 
[QGIS – Polygonize (Raster to vector)] 
(Menu bar » Raster » Conversion » Polygonize (Raster to vector)) 

 
I. Input file: "Result Raster 3 – High Potential SUDS Area" 

 
II. Output file for polygons (shapefile): "Result Vector 2 – High Potential 

SUDS Area" 
 

III. Field name: DN 

 
___________________________________________________________________ 

8.9 The created polygons may have a few topology errors, which could cause 
calculation errors. Step 9 (p. 74) describes some methods to check and 
correct the polygons.  
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Step 9 Check features for topology errors 
 

9.1 Because the "Result Vector 1 – Potential SUDS Area" and "Result Vector 
2 – High Potential SUDS Area" are created out of raster, there is the high 
chance for topological errors. With the [QGIS – Topology Checker] you 
can localise most of the errors in your data. 
 
[QGIS – Topology Checker] 
(install manually, if not already done) 
 
I. Menu bar » Plugins » Manage and Install Plugins… 

 
II. Search for "Topology Checker" 

 
III. Check Plugin 

 
IV. Menu bar » Vector » Topology Checker  

 
This will open a new Topology Checker Panel, looking something 
like Figure 29a. 
 

V. Open the "Topology Rule Settings" (see Figure 29a) 
 

VI. Add the rule ' "Result Vector 1 – Potential SUDS Area" must not 
have invalid geometries ' and "Result Vector 2 – High Potential 
SUDS Area" must not have invalid geometries '. This could look 
something like Figure 29b). 

 
VII. Validate all 

 
By validate the layer, you should see all areas with errors (If not 
continue with Step 9.2) 
 

  

 
Figure 43:  a) The Topology Checker Panel with button explanation and b) example 

working sheet for the Topology Rule Settings. 
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___________________________________________________________________ 
9.2 Sometimes the [QGIS – Topology Checker] does not show invalid 

geometries. If this is the case, you should check the polygons manually. 
The most likely reason for invalid geometries are two nodes with same 
coordinates (see Figure 44a for typical errors). 

 
__________________________________________________________________ 

9.3 Adjust the errors by: 
 
I. Delete one of the nodes 

 
II. Move one node  

 
In Figure 44b you can see the result of such adjustments. 

 
How to edit and delete nodes is described in Chapter 2 step 7.2. 

 

 
Figure 44:  Example of polygonised raster, a) show the typical errors by two nodes with 

the same coordinates and b) possible error corrections by deleting one of the 
nodes for the upper error and just moving one of the nodes for the lower error. 
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6 SUDS Area Detection Algorithm – Combined models 
 
To simplify the GIS process for getting the Potential SUDS Areas, Main Flow Paths 
and High Potential SUDS Areas, we have summarized all used GIS-tools into three 
QGIS models. You can download these models at www.klima2050.no and install them 
by just copy and paste the model data; 
 

"Potential SUDS Area Detection.model" 
"Main Flow Path Determination.model" 
"High Potential SUDS Area Detection.model" 
 

into the following QGIS user data installation folder: 
C:\Users\<User>\.qgis2\processing\models 

 
This chapter will give you a stepwise description of the usage of these QGIS models 
to create the Potential SUDS Areas, Main Flow Paths and High Potential SUDS 
Areas. A detailed description of all used GIS tools will then be given in the next chapter 
"SUDS Area Detection Algorithm – ". The numbering of the Input and Output Raster and 
Vector data follow the numbering in the chapter "SUDS Area Detection Algorithm – ". 
 
It is required to use the same coordination reference system (CRS) for all input 
data. See Chapter 2 about how to set the CRS. 
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Model 1 Potential SUDS Area Detection 
 

1.1 The first model of the algorithm creates raster and vector data to show 
Potential SUDS Areas used in the Decision Support Method. These areas 
show locations in the catchment, where SUDS applications are 
recommended due to the landuse and surface slope. Figure 45a shows 
an example of input data from the study case in Trondheim (Muthanna et 
al., 2018). Figure 45b shows an example of the output of the analysis.  
 
(This model combines tools used in Chapter "SUDS Area Detection 
Algorithm – ", Step 1, Step 2, Step 4 and Step 5.) 
 
[QGIS Model 1 - Potential SUDS Area Detection] 
(Processing Toolbox » search for: 1 - Potential SUDS Area Detection) 
 
III. Input Raster – Digital Terrain Model (dtm): "Raster 3 – converted 

dtm" 
 

IV. Input Vector – Catchment Area: "Vector 10 – catchment area" 
 

V. Input Vector – Landuse for SUDS application: "Vector 8 – landuse" 
 

VI. Minimum Surface Slope (%): 0% (default value) 
 

VII. Maximum Surface Slope (%): 10% (default value for swales) 
 

VIII. Output Raster – Digital Terrain Model Clipped: "Raster 5 – dtm 
clipped" 

 
Dtm raster clipped to the catchment area. 

 
IX. Output Raster – Potential SUDS Areas: "Result Raster 1 – 

Potential SUDS Area" 
 
A raster showing all Potential SUDS Areas with the cell value 1. 

 
X. Output Raster – Slope: "Raster 15 – Slope" 

 
A raster giving slope values, calculated by the 9 parameter 2nd order 
method(Zevenberg and Thorne 1987). 
 

XI. Output Vector – Potential SUDS Areas: "Result Vector 1 – 
Potential SUDS Area" 
 
Polygons showing all Potential SUDS Areas 

___________________________________________________________________ 
1.2 The created polygons in "Result Vector 1 – Potential SUDS Area" will 

have a few topology errors, which could cause calculation errors. Chapter 
"SUDS Area Detection Algorithm – ", Step 9 (p. 74) describes some 
methods to check and correct these polygons. 
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Figure 45:  a) Example Input Vectors showing building polygons in black, landuse polygons 

which enable SUDS applicates in green and elevation lines (not needed in the 
model). b) Example Output Vector for "Potential SUDS Areas", highlighted in blue 
and a WMS background map. 

  

 b) a) 
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Model 2 Main Flow Path Determination 
 

2.1 The second model of the algorithm creates raster and vector data to show 
Main Flow Paths used in the Decision Support Method. Main Flow Paths 
are regions with high surface runoff collection and are calculated by the 
flow accumulation in the catchment area. Therefore, it needs input data 
prepared in Chapter 2 and for "Model 1 - Potential SUDS Area Detection".  
 
Model 2 needs two separated model-parts to run. In the first model-part 
we will calculate the flow accumulation using elevation data. It combines 
the tools used in Chapter "SUDS Area Detection Algorithm – ", Step 3 and 
Step 6. 
 
[QGIS Model 2-1 – Main Flow Path Determination] 
(Processing Toolbox » search for: 2-1 – Main Flow Path Determination) 
 
I. Input Raster – Digital Terrain Model (dtm): "Raster 3 – converted 

dtm" 
 

II. Input Raster – Digital Surface Model (dsm): "Raster 4 – converted 
dsm" 

 
III. Input Vector – Catchment Area: "Vector 10 – catchment area" 

 
IV. Input Vector – Buildings: "Vector 7 – buildings" 

 
V. Output Raster – Combined Elevation Model: "Raster 13 – combined 

elevation model" 
 

A raster showing an elevation model which combine DSM elevation 
data for buildings and DTM elevation data for the terrain. Local 
depressions in the DTM are filled using "Fill sinks xxl (Wang & Liu)" 
from the SAGA GIS toolbox. You can see an example raster in 
Figure 46a. 

 
VI. Output Raster – Flow Accumulation: "Raster 18 – flow 

accumulation" 
 
A raster showing the flow accumulation, calculated by "Catchment 
area (flow tracing)" from the SAGA GIS toolbox. You can see an 
example raster in Figure 46b. 

 
VII. Output Vector – Flow Accumulation Points: "Vector 11 – flow 

accumulation points" 
 
Vector points showing all cells from the Flow Accumulation raster. 



S u s t a i n a b l e  u r b a n  d r a i n a g e  s y s t e m s  ( S U D S )  a r e a  d e t e c t i o n  u s i n g  G I S  

 80 

 
Figure 46:  a) Example Input Raster "Combined Elevation Model" with data from the dtm 

for terrain and from dsm for buildings, also a WMS background map. b) 
Example Output Raster for flow accumulation, from low (blue) to high (red) 
accumulation and a WMS background map. 

___________________________________________________________________ 
2.2 Next, we use model-part 2-2. This model-part combines the tools used in 

Chapter "GIS Decision Method – Single Tool Usage", Step 7. As a result 
we get the final vector data for the Main Flow Paths (see Figure 47). 
 
[QGIS Model 2-2 – Main Flow Path Determination] 
(Processing Toolbox » search for: 2-2 – Main Flow Path Determination) 
 
I. Input Vector – Flow Accumulation Points: "Vector 11 – flow 

accumulation points" 
 

II. Output Vector – Main Flow Path Points: "Vector 13 – Main Flow 
Path points" 

 
Selected Flow Accumulation Points from the Input Vector, which 
show the Main Flow Path. Main Flow Path Points are all points with 
a flow accumulation value greater than the root mean square of all 
flow accumulation values. 

 b) a) 
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Figure 47:  Example Output Vector "Main Flow Path Points" in red and a WMS background 

map. 
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Model 3 High Potential SUDS Area Detection 
 

3.1 The third and last model of the algorithm creates raster and vector data to 
show High Potential SUDS Areas used in the Decision Support Method. 
These areas show locations in the catchment, where SUDS applications 
are highly recommended due to the landuse and surface slope from the 
Potential SUDS Area Detection, and the close distance to lower Main Flow 
Paths. For this we use input data created in Chapter 2, in "Model 1 - 
Potential SUDS Area Detection" and in "Model 2 - Main Flow Path 
Determination". Figure 48a) shows example input data from the case 
study in Trondheim (Muthanna et al., 2018). Figure 48b) shows an 
example of output data.  
 
This model combines the tools used in Chapter "SUDS Area Detection 
Algorithm – ", Step 8.  
 
[QGIS Model 3 – High Potential SUDS Area Detection] 
(Processing Toolbox » search for: 3 – High Potential SUDS Area 
Detection) 
 
I. Input Raster – Digital Terrain Model (DTM): "Raster 3 – converted 

dtm" 
 

II. Input Raster – Potential SUDS Areas: "Result Raster 1 – Potential 
SUDS Area" 

 
III. Input Vector – Catchment Area: "Vector 10 – catchment area" 

 
IV. Input Vector – Main Flow Path Points: "Vector 13 – Main Flow Path 

points" 
 

V. Maximum Distance to Main Flow Path (m): 100 (default) 
 

The maximum distance between the Main Flow Paths and the 
nearest Potential SUDS Area, to create a High Potential SUDS 
Area. 

 
VI. Output Raster – High Potential SUDS Areas: "Result Raster 3 – 

High Potential SUDS Area" 
 
A Raster showing all High Potential SUDS Areas with the cell value 
1. 

 
VII. Output Vector – High Potential SUDS Areas: "Result Vector 2 – High 

Potential SUDS Area" 
 
Polygons showing all High Potential SUDS Areas. In Figure 48b you 
can see example Vector Polygons. 

___________________________________________________________________ 
3.2 The created polygons in "Result Vector 2 – High Potential SUDS Area" 

may have a few topology errors, which could cause calculation errors. 
Chapter "SUDS Area Detection Algorithm – ", Step 9 (p. 74) describes some 
methods to check and correct these polygons. 
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Figure 48:  a) Example Input Vector "Potential SUDS Areas" in blue and a WMS 

background map. b) Example Input Vectors for "Main Flow Path points" in red 
and the resulting Output Vector "High Potential SUDS Area" in blue, also 
showing a WMS background map. 

 

 
 
 
 

 b) a) 
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